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LTspice — Installation und Inbetriebnahme

Installation

Um die Simulation durchfiihren zu kénnen, muss die Software LTspice unter folgender Adresse heruntergeladen
werden:

http://www.linear.com/designtools/software/ltspice.jsp

Falls ihr euch nicht bei dem Hersteller registrieren méchtet, wéhlt “No thanks, just download the software”. Fir
zukiinftige automatische Updates musst ihr euch registrieren und “Register for a new MyLinear account’
wahlen. Dann musst ihr das selbstextrahierende Archiv LTspicelV.exe* anklicken und die Installation
durchfiihren. Klickt ,Accept® und wahlt ein Installationsverzeichnis. AnschlieBend klickt ,Install Now“. Die
Installation dauert ein paar Minuten (ca. 5 Minuten) und am Ende erscheint ein Fenster ,LTspice IV has been
successfully installed“ als Zeichen, dass die Installation erfolgreich durchgefihrt wurde. Klickt ,OK*, damit
LTspice automatisch startet.

Inbetriebnahme

Erstellt das Verzeichnis ,c:\ilca3_ltspice®, in dem alle Simulationsdateien gespeichert werden. Kopiert die Datei
,2Jebertragungsleitung2.asc” in das Verzeichnis, die ihr von der Intel® Leibniz Challenge Webseite herunterladen
konnt. Offnet die Datei, indem ihr im Menii ,File* den Eintrag ,Open“ auswahit. AnschlieRend misst ihr in dem
Fenster ,Open an existing file*, die Datei ,Uebertragungsleitung2.asc* auswéhlen und 6ffnen.

Mit der geoffneten Datei ist es moglich zu testen, ob die Installation erfolgreich war. Startet die Simulation ber
den Menipunkt ,Simulate = Run* und 0berprift, ob in dem Verzeichnis ,c:\ilca3_ltspice” die Datei
,Uebertragungsleitung2.raw* erstellt wurde. Falls dies der Fall ist, war die Installation erfolgreich. Uber den
Meniipunkt ,File = Exit* konnt ihr das Programm beenden.

Tipps und Tricks
e Verschieben eines Symbols/Elementes im Schaltplan (schematic)
,Edit > Move" bzw. F7 = mit der linken Maustaste Element auswahlen und verschieben = Esc
e Drehen eines Symbols/Elementes im Schaltplan
Auswahl des Elementes (vgl. Verschieben eines Symbols®) - ,Edit - Rotate“ bzw. Strg + R > Esc
e LoOschen eines Symbols/Elementes im Schaltplan
,Edit > Delete" bzw. F5 = mit der linken Maustaste ein Element I6schen = Esc
o Verdndern des Namens eines Symbols/Elementes

Mit der rechten Maustaste den Namen eines Elementes auswahlen = den Namen in dem Fenster ,Enter
new reference designator for* andern.

Beispielsweise kann der Name einer Spannungsquelle von V1 in V2 umbenannt werden.
e Verandern der Eigenschaften eins Symbols/Elementes

Mit der rechten Maustaste ein Elementes auswéhlen = in dem sich 6ffnenden Fenster die Eigenschaften
andern.

e Eine Veranderung riickgangig machen
,Edit > Undo" bzw. F9
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LTspice — Aufgabe 3.2

Fur Aufgabe 3.2.1) soll das Schaltbild nach Abbildung 5 erstellt werden, wobei folgende Vorgehensweise
empfohlen wird.

1. Startet LTspice
2. Erstellt neues Schaltbild: ,File > New Schematic*
3. Speichert das Schaltbild als ,Kennlinienl.asc": ,File = Save As*

4. \Wahlt den Transistor aus der Liste von Komponenten aus: ,Edit > Component" bzw. F2 > Gebt ,nmos4‘
in das Eingabefeld ein. > ,0K"

5. Platziert den NMOS-Transistor in die Mitte des Schaltbildes. Klickt mit der linken Maustaste, um den
Transistor zu platzieren. Schlieft den Vorgang mit der Taste Esc ab.

6. Verdndert die Eigenschaften des Transistors, indem ihr mit der rechten Maustaste auf das Symbol des
Transistors klickt, sodass folgendes Fenster erscheint:

Monolithic MOSFET - M1 X

Model Name: |NMOS [

Length(LL: [ Concel ]
widthlw]: | <\ eingeber:
Dirain ArealsD): l:l
Source ArealdsS): l:|
Drrain Perimeter[PD]: I:I
Source PerimeterPS]: I:I
Mo. Parallel Devices(M): I:I

MMOS |=<L eingebeny w=:W eingeben:

7. Setzt folgende Parameter:
Model Name: NMOS (ist bereits eingetragen)
Length (L): 32u
Width (W): 100u

Weitere Werte sollen nicht festgelegt werden, damit Standardwerte verwendet werden. Schlief3t den Vorgang
mit OK ab.

8. Wahlt eine Spannungsquelle aus der Liste der Komponenten aus: ,Edit - Component bzw. F2 - Gebt
,voltage" in das Eingabefeld ein. > ,0K" - Platziert die Spannungsquelle im Schaltbild (vgl. Punkt 5) -
Klickt auf die Spannungsquelle mit der rechten Maustaste, sodass folgendes Fenster erscheint:

Voltage Source - ¥1

DC valuelv] |:|
-—C |

Series Resistance[R2]: l:l ance
-Advanced

Beendet die Eingabe mit OK, wobei hier keine Werte eingetragen werden soll. Dieser Punkt ist wichtig und
darf nicht ibergangen werden.

9. Erzeugt eine zweite Spannungsquelle im Schalthild, indem ihr den Punkt 8 vollstandig wiederholt.
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LTspice — Aufgabe 3.2

10. Wahlt einen Widerstand aus der Liste der Komponenten aus: ,Edit > Component* bzw. F2 > Gebt ,res"
in das Eingabefeld ein. > ,0K" - Platziert den Widerstand im Schaltbild (vgl. Punkt 5) = Klickt auf den
Widerstand mit der rechten Maustaste, sodass folgendes Fenster erscheint:

Resistor - R1 |£‘
Manufacturer, -
Part Mumber: - -

Select Resistor
Reszistar Properties
Resistance[]:
Talerancel%] l:l

Paower R ating[w] l:l

11. Setzt den Parameter ,Resistance[Q]“ auf den Wert 100. Die anderen Parameter sollen nicht festgelegt
werden. Beendet die Eingabe mit OK.

12. Erzeugt einen zweiten Widerstand, indem ihr die Punkte 10 und 11 wiederholt. Dieser Widerstand muss (ber
den Befehl ,Edit > Rotate" bzw. Strg + R gedreht werden.

13. Nun missen die einzelnen Bauelemente untereinander elektrisch verbunden werden. Wahlt dazu ,Edit >
Draw Wire" bzw. F3. Zeichnet die Verbindungen, indem ihr mit der linken Maustaste jeweils den Anfangs-
und Endpunkt der Verbindungsleitung festlegt. Die Anschliisse der einzelnen Elemente sind mit blauem
Rechteck markiert.

14. Jede Schaltung bendtigt ein Referenzpotential (Masse, GND). Erzeugt ein solches Referenzpotential, indem
ihr das GND Symbol auswahlt (,Edit - Place GND* bzw. g) und platziert. Verbindet dieses Symbol mit dem
Anschluss .~ der Spannungsquelle (vgl. Punkt 13).

15. Speichert nun das Schaltbild: ,File - Save*

In Aufgabe 3.2.2) soll die erstellte Schaltung simuliert werden:

16. Um die Simulation vorzubereiten, missen einzelnen Simulationsparameter festgelegt werden: ,Simulate >
Edit Simulation Cmd". Da die Spannungen V1 und V2 verandert werden sollen, wéhlt ,DC sweep":

Edit Simulation Command |£| Edit Simulation Command |§|
| Transient | AC AnalyskLDE SV\WNoise | DC Trarster | DC op prit| | Transient | AC Analysis| DC sweep | Noise | DE Transfer | DC op prit|
Compute the DC operating point of a circuit while stepping independent sources and Compute the DC operating point of a circuit while stepping independent sources and
treating capacitances as open circuits and inductances as shart circuits. treating capacitances as open circuits and inductances as short circuits
e
‘ 2nd Source || 3d Source| st Souré 2nd SUUTCEA 3rd Source
Mame of 15t Source to Sweep: I:I Mame of 2nd Source to Sweep: I:I
Syntax: dc <Sourcel> [<octdec.lin:] <Start: <Stop> [<Incr] [<source2s ...] Syntax: .do <Sourcelr [<octdeclinz] <Start> <Stop> [<Incrr] [<source2> ..]

[ Cancel J E 0K

[ Cancel J E 0K
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17. Setzt folgende Parameter fest:

1st Source:

Name of 1st Source to Sweep: V1
Type of Sweep: Linear
Start Value: 0

Stop Value: 30
Increment: 1

2st Source:

Name of 1st Source to Sweep: V2
Type of Sweep: Linear
Start Value: 0

Stop Value: 10
Increment; 1

Schliel3t die Eingabe mit ,OK" ab und platziert die Simulationsanweisung (,.dc V1 0301 V2010 1) in dem
Schaltbild.

18. Startet die Simulation: ,Simulate = Run®, wobei sich hier ein Fenster ,Kennliniel.raw" automatisch offnet.

19. Auswahl der Signale wird durch ,View - Visable Traces" bzw. B ur Verfligung gestellt:

M Select Visible Waveforms |§|
Select Waveforms to Flot:
Cirl-Click to toggle

Cancel
Alt-D ouble-Click. to enter an expression
]
Wn002]
Vn003)
(004
I[R1]
I1R2)
In¥1]
I1¥2)
1b[h1)
Id[t1]
laf1]
Is{t1]
Auta Range i |

20. Wahlt I(R1), um den Strom durch den Widerstand R1 darzustellen. Das Ergebnis wird in dem Fester
.Kennliniel.raw" angezeigt.

21. Um das Ergebnis an uns zu senden, muss die Datei ,Kennliniel.raw* (Fenster ,Kennliniel.raw* anklicken =

o ) gespeichert und ein Screenshot (,Tools > Write plot to a .wmf file* > ,Kennliniel.wmf“) erstellt
werden.

Fur Aufgabe 3.2.3) und Aufgabe 3.2.4) muss die Weite des Transistors (W = 100 pm bzw. W = 300 pm?)
verandert werden (vgl. Punkt 6 und Punkt 7). AnschlieBend muss jeweils die Simulation wiederholt werden.

In Aufgabe 3.2.5) werden die Werte des Stromes lps gesucht, wobei dieser Strom in der Simulation als Ip
bezeichnet wird. Lest zunéchst fiir die Transistorweite W = 200 um die entsprechende Werte aus Abbildung 6 ab
und tragt sie in Tabelle 2 ein. AnschlieBend bestimmt ihr die Werte des Stromes lps fir die Weiten W = 32 pm,
W =100 pum und W =300 pum aus den Ergebnissen eurer Simulation.

Fir Aufgabe 3.2.7) muss der Strom I(R2) bestimmt werden, wobei hier die erste Simulation (W = 32 pm)
verwendet werden soll.

1 Beachtet, dass unter LTspice statt 1" ein ,u“ eingegeben werden muss.
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Fur Aufgabe 3.4.1) soll das Schaltbild nach Abbildung 10 erstellt werden, wobei hier zun&chst die Schritte 1 - 14
durchgefihrt werden mussen. Das Schaltbild soll dabei als ,Uebertragungsleitungl.asc* gespeichert werden.
Folgende Punkte miissen zusétzlich durchgefiinrt werden:

22. Wahlt einen Kondensator aus der Liste der Komponenten aus: ,Edit > Component” bzw. F2 > Gebt ,cap*
in das Eingabefeld ein. > ,0K" - Platziert den Kondensator im Schaltbild (vgl. Punkt 5) = Klickt auf den
Kondensator mit der rechten Maustaste, sodass folgendes Fenster erscheint:

Marufacturer, - o

Part Mumber:  -eeee

i —
Select Capacitor

Capacitor Froperties

CapacitancelFT:

‘“Waltage Rating[V]: l:l

RMS Current R ating[A]: l:l
Equiv. Series Resistance[g2]: l:l
Equiv. Senes Inductance[H]: l:l
Equiv. Parallel Resistance[]: l:l
Equiv. Paralel Capacitance[F]: l:l

23. Setzt den Parameter ,Capacitance[F]* auf den Wert 340f. Die anderen Parameter sollen nicht festgelegt
werden. Beendet die Eingabe mit ,0K".

24. Erzeugt einen zweiten Kondensator und setzt den Parameter ,Capacitance[F]* auf den Wert 40f.

25. Zwei Signale sollen mit den Buchstaben ,a“ und ,b“ benannt werden: ,Edit - Label Net* bzw. F4 = Tragt
den gewiinschten Namen (zuerst ,a“ und dann ,b“) unter ABC:

Net Name |X|
-0 GND(global node 0]
Lo
- < abzw. b eingeben 3|

[Part type is only visible if drawn at
the end af a wire ]

26. Platziert die Beschriftung so, dass das blaue Rechteck auf der entsprechenden Leitung liegt (vgl. Abbildung
10).

27. Nun muss die Spannungsquelle spezifiziert werden. Klickt auf die Spannungsquelle mit der rechten
Maustaste. Im ,Voltage Source V1“-Fenster wahlt ,Advanced”. Unter ,Functions” findet ihr ,PULSE" (fir
eine Pulsspannungsquelle). Setzt folgende Parameter:

Vinitial[V]: 0
Von([V]: 5
Tdelay[s]:  5n
Trise[s]: 0
Tfall[s]: 0
Ton[s]: 5n

Tperiod[s]: 10n
Ncycles: 2
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Yoltage Source - ¥1 Independent Voltage Source - V1 |z

Functions DC%alue

DE valuelV] Onore) DCvabe [ |

(&) PULSE[1 %2 Tdelay Trise Tall Ton Period Meycles) (Ve (5% frfiamettam il am eelametfes

SatzslreEEE e ) SINE[offset Yamp Freg Td Theta Phi Neycles)
O ERPNA Y2 Td1 Taul Td2 Tauz) Small signal AT analysis[.AC)
) SFFM(Vaff Vamp Fear MDI Fsig) ACAmpitude: ||
O PWL 112 v2.) AL Phase: |:|
) Pw/L FILE: e I ake thiz information visible on schematic:
| Farasitic Properties
Vinifalv} |0 Series Resistance[Q]
VonV} & Parallel Capacitance[F):
Tdelapls} |En ake thiz information visible on schematic:
Trize[s} O
Tfall[s} |0
Taonfs) |5
Tperiodzl | 10n
Nepcles: |
Additior
Make this information visible on schematic: [ Cancel } [ or ]

28. Um die Simulation vorzubereiten, miissen einzelnen Simulationsparameter festgelegt werden: ,Simulate >
Edit Simulation Cmd". In diesem Fall wird eine sogenannte transiente Simulation verwendet, die fur 30ns
durchgefiihrt wird (Parameter ,Stop Time*: 30n)

Edit Simulation Command | X ‘

o
( Transient PAE Analyzis " DC sweep ]m[ DC Transfer " DCop pnt]

Perfarm a noninear, time-daomain simulation

Stop Time: | 30r]

Time to Start Saving D ata:

 asimum Timestep:

Start extemal DC supply voltages at 0 []

Stop simulating if steady state is detected: [ |
Don't reset T=0 when steady state iz detected:

Step the load curent souce: [

Skip Initial operating paint solutian: ]

Syntax: tran <Tstop> [<option: [<option:] ...]

_hian 30n

29. Startet die Simulation und wahlt die Signale V(a) und V(b) aus, um sie im Fenster ,Uebertragungs-
leitungl.raw” zu sehen (vgl. Punkt 18 - 20).

30. Speichert die Ergebnisse der Simulation als ,Uebertragungsleitungl.raw* und ,Uebertragungsleitungl.wmf*
(vgl. Punkt 21).




|NTEt® LElBN|Z CHALLENGE Zusatzinformation 29.03.2010
‘ @ iNnTieTive DT

LTspice — Aufgabe 3.4

In den Aufgaben 3.4.3) - 3.4.5) verwendet ihr die Datei ,Uebertragungsleitung2.asc”, die ihr von der Intel®
Leibniz Challenge Webseite herunter laden konnt.

31. Offnet die Datei ,Uebertragungsleitung2.asc": ,File > Open*
In Aufgabe 3.4.5) solltet ihr die die Signalverzégerung zwischen zwei Signalen bestimmen.

32. Die Signalverzdgerung muss zwischen zwei identischen Werten des Signals gemessen werden. In dieser
Aufgabe werden wir die Stellen betrachten, an denen die Signale 50% der maximalen Spannung erreichen
(positive Flanke), wobei in der Aufgabe dieser Wert einer Spannung von 2,5V entspricht. Wenn ihr nun in der
,Uebertragungsleitung2.raw“-Fenster mit der Maus auf die einzelnen Punkte der Signalverlaufe zeigt, wird in
der linken Ecke der genaue Wert (Zeitpunkt (x-Wert) und Spannungswert (y-Wert)) dargestellt:

4.8V

4.2V

3.6V

3.0¥+

2.4¥—

1.8¥

1.2V

0.6V

0.0V~

0.6V

H1.2y. .

T T T
Ons m 2ns Ins 4ns 5nd
x=5.12ns y=2.501¥ )
tt b

33. Nachdem ihr die Zeitpunkte bestimmt habt, an denen die Signale den Wert 2,5V (iberschreiten, konnt ihr die
Signalverzégerung bestimmen (t; - ta).

T
bns

Fir Aufgabe 3.4.6) misst ihr die Parameter der einzelnen Transistoren verandern.

34. Die Vorgehensweise ist in den Punkten 6 und 7 erlautert. Nach jeder Anderung muss eine Simulation
durchgefiihrt werden, um die Auswirkung der Anderungen beurteilen zu kénnen.
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Amerikanische Symbole vs. DIN-Symbole

LTspice verwendet die amerikanischen Symbole zur Darstellung elektronischer Bauelemente. Die folgende
Tabelle stellt die verwendeten Symbole und deren Entsprechung in der DIN-Norm zusammen:

Bezeichnung LTspice - Symbol DIN - Symbol

Widerstand

Kondensator

Spannungsquelle

Masse (GND)




